how to install essential codecs from rpmfusion to gstreamer 1.0 comparable to current script for gstreamer0.1

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

how to install essential codecs from rpmfusion to gstreamer 1.0 comparable to current script for gstreamer0.1

tony37
Your question is how to abstract the filesystem changes made by
install of non-free codecs from the rpmfusion repository on a
Fedora 18 system.

On Mon, Feb 01, 2016 at 11:42:57AM +0800, Tony Anderson wrote:
Aside from my rants, this is the crux. If I could have a script which installs
these files in gstreamer 1.0, I would be happy to upgrade.
While I haven't made a try in a couple of years, I was unable to find where
gstreamer 1.0 expects these libraries to be. The files are
different for xo-1 and xo-1.5, xo-1.75, and xo-4. Meanwhile, jukebox-26 with
gstreamer 0.1 works fine with 0.106.

Tony

	 sudo cp libgstmad.so /usr/lib/gstreamer-0.10/
         sudo chmod 755 /usr/lib/gstreamer-0.10/libgstmad.so
         sudo cp libmad.so.0 /usr/lib
         sudo chmod 755 /usr/lib/libmad.so.0
         sudo cp libgstfaad.so /usr/lib/gstreamer-0.10
         sudo chmod 755 /usr/lib/gstreamer-0.10/libgstfaad.so
         sudo cp libfaad.so.2.0.0 /usr/lib
         sudo chmod 755 /usr/lib/libfaad.so.2.0.0
         sudo yum install gstreamer-ffmpeg-0.10.13-8.fc18.i686.rpm
         sudo ldconfig
         sudo rm -rf /home/olpc/.gstreamer-0.10/registry.i386.bin
        > 
        > This script installs the necessary codes directly. I am sure the
        > ffmpeg install adds unnecessary code but I don't know how to break
        > this out. However, this script does not work with gstreamer 1.0 and
        > I have spent hours researching the documentation to find out what
        > happened to the libgst* libraries and the registry.i386.bin. The
        > only documentation I found requires installing the complete bad and
        > ugly libraries (granted, this was a couple of years ago so that
        > documentation may now exist - but gstreamer 0.1 works with no
        > problems so no need to spend more time on it).


_______________________________________________
Devel mailing list
[hidden email]
http://lists.laptop.org/listinfo/devel
Reply | Threaded
Open this post in threaded view
|

Re: how to install essential codecs from rpmfusion to gstreamer 1.0 comparable to current script for gstreamer0.1

James Cameron-2
In the GStreamer 0.1 to 1.0 transition, the codecs and dependencies
changed, in particular gstreamer1-libav should be substituted for
gstreamer-ffmpeg.

These codecs you asked about are third-party software that do not meet
the OLPC standards for software freedom.  The use of such software is
unsupported; OLPC does not endorse or encourage its use.

Also, OLPC doesn't don't support your method of changing the
filesystem, instead we provide olpc-os-builder, because it works with
our olpc-update feature.  The codecs you asked about can be added to
your builder configuration;

        http://wiki.laptop.org/go/OS_Builder/Add_Restricted

Many deployments use my restricted software builds, which are based on
the open source builds, but are not available for public download.

Using a restricted software build from me means you don't have to
rerun the builder.  The build installs as usual, and has the codecs
you asked about preinstalled.

My restricted software builds are made in Australia from imported
components, using the same infrastructure as the open source builds.

If you refuse to use my restricted builds, refuse to use the builder,
don't mind your changes being lost when you use olpc-update, and don't
mind having to scale your change up to multiple laptops, then you can
add codecs after install:

sudo yum localinstall -y \
http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm \
http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm && \
sudo yum install -y \
  gstreamer1-{plugins-{ugly,bad-free{-extras,world},base-tools,good-extras,bad-free},libav} \
  gstreamer-{plugins-{ugly,bad},ffmpeg}

You may abstract the filesystem changes by comparing the filesystem
before and after.  I've done that with rsync between systems, in
--dry-run mode, to generate a list of changes, then tar up the changed
files.

Or, you can set keepcache=1 in /etc/yum.conf before the above install,
and save the RPMs.

Hope that helps.

References:

http://wiki.laptop.org/go/GStreamer (updated today)
http://dev.laptop.org/git/projects/olpc-os-builder/tree/restricted-0.ini?h=v7.0-restricted
http://dev.laptop.org/git/projects/olpc-os-builder/tree/restricted-1.ini?h=v7.0-restricted
http://dev.laptop.org/git/projects/olpc-os-builder/tree/restricted-2.ini?h=v7.0-restricted
http://dev.laptop.org/git/projects/olpc-os-builder/tree/restricted-4.ini?h=v7.0-restricted

On Mon, Feb 01, 2016 at 01:52:19PM +0800, Tony Anderson wrote:

> Your question is how to abstract the filesystem changes made by
> install of non-free codecs from the rpmfusion repository on a
> Fedora 18 system.
>
> On Mon, Feb 01, 2016 at 11:42:57AM +0800, Tony Anderson wrote:
>
>     Aside from my rants, this is the crux. If I could have a script which installs
>     these files in gstreamer 1.0, I would be happy to upgrade.
>     While I haven't made a try in a couple of years, I was unable to find where
>     gstreamer 1.0 expects these libraries to be. The files are
>     different for xo-1 and xo-1.5, xo-1.75, and xo-4. Meanwhile, jukebox-26 with
>     gstreamer 0.1 works fine with 0.106.
>
>     Tony
>
>          sudo cp libgstmad.so /usr/lib/gstreamer-0.10/
>          sudo chmod 755 /usr/lib/gstreamer-0.10/libgstmad.so
>          sudo cp libmad.so.0 /usr/lib
>          sudo chmod 755 /usr/lib/libmad.so.0
>          sudo cp libgstfaad.so /usr/lib/gstreamer-0.10
>          sudo chmod 755 /usr/lib/gstreamer-0.10/libgstfaad.so
>          sudo cp libfaad.so.2.0.0 /usr/lib
>          sudo chmod 755 /usr/lib/libfaad.so.2.0.0
>          sudo yum install gstreamer-ffmpeg-0.10.13-8.fc18.i686.rpm
>          sudo ldconfig
>          sudo rm -rf /home/olpc/.gstreamer-0.10/registry.i386.bin
>         >
>         > This script installs the necessary codes directly. I am sure the
>         > ffmpeg install adds unnecessary code but I don't know how to break
>         > this out. However, this script does not work with gstreamer 1.0 and
>         > I have spent hours researching the documentation to find out what
>         > happened to the libgst* libraries and the registry.i386.bin. The
>         > only documentation I found requires installing the complete bad and
>         > ugly libraries (granted, this was a couple of years ago so that
>         > documentation may now exist - but gstreamer 0.1 works with no
>         > problems so no need to spend more time on it).
>

> _______________________________________________
> Devel mailing list
> [hidden email]
> http://lists.laptop.org/listinfo/devel


--
James Cameron
http://quozl.netrek.org/
_______________________________________________
Devel mailing list
[hidden email]
http://lists.laptop.org/listinfo/devel