Firefox on XO

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Firefox on XO

T Gillett
Hi All

I have installed Firefox on the current 13.2.8 build on XO-1.5 and it works OK except that there is no sound on some websites.
Other sites work OK.

This seems to be a known problem:
    https://bugzilla.mozilla.org/show_bug.cgi?id=803042
    http://forums.fedoraforum.org/showthread.php?t=277040
    https://ask.fedoraproject.org/en/question/65978/fedora-21-firefox-3603-and-flash-no-sound-system-sound-fine/
The issue seems to revolve around getting FF to use ALSA for sound, and without installing PulseAudio.
 
I am wondering if anyone using Firefox on XO has encountered and/or solved this problem.

Thanks in advance for any help on this.
Terry

------------------------

Some sites for testing the audio. Open any of these in a new tab and you should hear audio.
No sound on XO.

3.    http://robbbenson.com/01%20Eve.mp3
Sound OK.

_______________________________________________
Devel mailing list
[hidden email]
http://lists.laptop.org/listinfo/devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Firefox on XO

T Gillett
I should also mention that sound plays OK in Epiphany on the sites where it won't play on FF.
So the issue seems to lie with FF...

On Sun, Jan 1, 2017 at 8:52 AM, T Gillett <[hidden email]> wrote:
Hi All

I have installed Firefox on the current 13.2.8 build on XO-1.5 and it works OK except that there is no sound on some websites.
Other sites work OK.

This seems to be a known problem:
    https://bugzilla.mozilla.org/show_bug.cgi?id=803042
    http://forums.fedoraforum.org/showthread.php?t=277040
    https://ask.fedoraproject.org/en/question/65978/fedora-21-firefox-3603-and-flash-no-sound-system-sound-fine/
The issue seems to revolve around getting FF to use ALSA for sound, and without installing PulseAudio.
 
I am wondering if anyone using Firefox on XO has encountered and/or solved this problem.

Thanks in advance for any help on this.
Terry

------------------------

Some sites for testing the audio. Open any of these in a new tab and you should hear audio.
No sound on XO.

3.    http://robbbenson.com/01%20Eve.mp3
Sound OK.


_______________________________________________
Devel mailing list
[hidden email]
http://lists.laptop.org/listinfo/devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Firefox on XO

James Cameron-2
In reply to this post by T Gillett
G'day Terry,

You didn't mention which version of Firefox.

With firefox-26.0-2 from the Fedora 18 repository your no-sound issue
with those sites reproduces.

Then I installed apulse, a PulseAudio emulation for ALSA, but the
problem persisted.  Looking at /proc/$(pidof firefox)/smaps the
libpulse libraries are not mapped.

Which Firefox are you trying, and how are you trying it?

References:

https://github.com/i-rinat/apulse (source)
https://github.com/vitvegl/apulse-rpm (for the spec file)

dependencies: gcc-c++ gcc-sh-linux-gnu cmake alsa-lib-devel glib2-devel alsa-lib glib2

On Sun, Jan 01, 2017 at 08:52:39AM +1000, T Gillett wrote:

> Hi All
>
> I have installed Firefox on the current 13.2.8 build on XO-1.5 and it works OK
> except that there is no sound on some websites.
> Other sites work OK.
>
> This seems to be a known problem:
>     [1]https://bugzilla.mozilla.org/show_bug.cgi?id=803042
>     [2]http://forums.fedoraforum.org/showthread.php?t=277040
>     [3]https://ask.fedoraproject.org/en/question/65978/fedora-21-fi
> refox-3603-and-flash-no-sound-system-sound-fine/
>     [4]http://unix.stackexchange.com/questions/144395/
> firefox-html5-asoundrc-no-sound
>
> The issue seems to revolve around getting FF to use ALSA for sound, and without
> installing PulseAudio.
>  
> I am wondering if anyone using Firefox on XO has encountered and/or solved this
> problem.
>
> Thanks in advance for any help on this.
> Terry
>
> ------------------------
>
> Some sites for testing the audio. Open any of these in a new tab and you should
> hear audio.
>
> 1.    [5]http://student.readingeggs.com//sample_lessons/#/sample/lesson/6/
> activity/1
> No sound on XO.
>
> 2.    [6]http://vt-motoli.org/CG/cg_03/cg_03.html#l-en
> No sound on XO.
>
> 3.    [7]http://robbbenson.com/01%20Eve.mp3
> Sound OK.
>
> References:
>
> [1] https://bugzilla.mozilla.org/show_bug.cgi?id=803042
> [2] http://forums.fedoraforum.org/showthread.php?t=277040
> [3] https://ask.fedoraproject.org/en/question/65978/fedora-21-firefox-3603-and-flash-no-sound-system-sound-fine/
> [4] http://unix.stackexchange.com/questions/144395/firefox-html5-asoundrc-no-sound
> [5] http://student.readingeggs.com//sample_lessons/#/sample/lesson/6/activity/2
> [6] http://vt-motoli.org/CG/cg_03/cg_03.html#l-en
> [7] http://robbbenson.com/01%20Eve.mp3

> _______________________________________________
> Devel mailing list
> [hidden email]
> http://lists.laptop.org/listinfo/devel


--
James Cameron
http://quozl.netrek.org/
_______________________________________________
Devel mailing list
[hidden email]
http://lists.laptop.org/listinfo/devel
Loading...