Auckland Testing Summary 18 May 2013

classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|

Auckland Testing Summary 18 May 2013

carrott
Auckland Testing Summary 18 May 2013
Who: John, Oliver, Tabitha, Tom

Testing One Education OS 1.2 (build au889) on XO-1.75 and XO-system 1a
for XO-4 (build 32) on XO-4.

One Education OS 1.2 (build au889) on XO-1.75:
Sound doesn’t work due to OLPC #12637 downgrading the firmware to Q4D24
fixes it.

Browse is really old and slow! Many websites work badly!

Measure works

Maze works with 2 way collaboration on adhoc wifi

Paint works, can easily change fonts when writing
basic test works - labyrinth, implode, maze, memorize, moon, ruler,
tamtam mini, numbers, speak, record, clock, stopwatch

XO-system 1a for XO-4 (build 32):
no get books??
Somehow the top hit in aslo for get books waas get internet archive
books (version 6) but install fails with error:
sugar3.bundle.bundle.MalformedBundleException: Activity bundle
/home/olpc/.sugar/default/data/d84ff538-7200-47b1-92fd-2e4962f73e50_dQxXr5.xo
does not specify a bundle id
Regular get books installs and works well

read works

color chooser in write is laggy, but otherwise write works

tamtam mini 67 got caught in an inifnite loop, see
https://sugardextrose.org/issues/3880 this was not repeatable

paint- can’t choose font when using text boxes with trackpad or
touchscreen maybe due to wear the menu drops down, bold and italic works

works - moon, maze, implode, memorize, clock, stopwatch, physics, write
nice improvements in speak for visual tool identification
nice improvements in record for visual tool identification

ran software updates - fraction bounce and level activities work

write full test works
record works
browse basic test works

_______________________________________________
Testing mailing list
[hidden email]
http://lists.laptop.org/listinfo/testing

powerlogs.tar.bz2 (20K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Auckland Testing Summary 18 May 2013

James Cameron-2
On Sat, May 18, 2013 at 03:52:42PM +1200, Tom Parker wrote:
> Auckland Testing Summary 18 May 2013
> Who: John, Oliver, Tabitha, Tom
>
> Testing One Education OS 1.2 (build au889) on XO-1.75 and XO-system
> 1a for XO-4 (build 32) on XO-4.
>
> One Education OS 1.2 (build au889) on XO-1.75:
> Sound doesn’t work due to OLPC #12637 downgrading the firmware to
> Q4D24 fixes it.

What firmware version was installed?

What firmware version is in au889?

>
> Browse is really old and slow! Many websites work badly!
>
> Measure works
>
> Maze works with 2 way collaboration on adhoc wifi
>
> Paint works, can easily change fonts when writing
> basic test works - labyrinth, implode, maze, memorize, moon, ruler,
> tamtam mini, numbers, speak, record, clock, stopwatch
>
> XO-system 1a for XO-4 (build 32):
> no get books??
> Somehow the top hit in aslo for get books waas get internet archive
> books (version 6) but install fails with error:
> sugar3.bundle.bundle.MalformedBundleException: Activity bundle /home/olpc/.sugar/default/data/d84ff538-7200-47b1-92fd-2e4962f73e50_dQxXr5.xo
> does not specify a bundle id
> Regular get books installs and works well
>
> read works
>
> color chooser in write is laggy, but otherwise write works
>
> tamtam mini 67 got caught in an inifnite loop, see
> https://sugardextrose.org/issues/3880 this was not repeatable
>
> paint- can’t choose font when using text boxes with trackpad or
> touchscreen maybe due to wear the menu drops down, bold and italic
> works
>
> works - moon, maze, implode, memorize, clock, stopwatch, physics, write
> nice improvements in speak for visual tool identification
> nice improvements in record for visual tool identification
>
> ran software updates - fraction bounce and level activities work
>
> write full test works
> record works
> browse basic test works


> _______________________________________________
> Devel mailing list
> [hidden email]
> http://lists.laptop.org/listinfo/devel


On Sat, May 18, 2013 at 04:06:45PM +1200, Tabitha Roder wrote:

> ---------- Forwarded message ----------
> From: "Tom Parker" <[hidden email]>
> Date: 18/05/2013 3:53 PM
> Subject: [OLPC New Zealand] Auckland Testing Summary 18 May 2013
> To: "[hidden email]" <[hidden email]>, "OLPC testing" <
> [hidden email]>, "OLPC Devel" <[hidden email]>
> Cc:
>
> Auckland Testing Summary 18 May 2013
> Who: John, Oliver, Tabitha, Tom
>
> Testing One Education OS 1.2 (build au889) on XO-1.75 and XO-system 1a for XO-4
> (build 32) on XO-4.
>
> One Education OS 1.2 (build au889) on XO-1.75:
> Sound doesn’t work due to OLPC #12637 downgrading the firmware to Q4D24 fixes
> it.
>
> Browse is really old and slow! Many websites work badly!
>
> Measure works
>
> Maze works with 2 way collaboration on adhoc wifi
>
> Paint works, can easily change fonts when writing
> basic test works - labyrinth, implode, maze, memorize, moon, ruler, tamtam
> mini, numbers, speak, record, clock, stopwatch
>
> XO-system 1a for XO-4 (build 32):
> no get books??
> Somehow the top hit in aslo for get books waas get internet archive books
> (version 6) but install fails with error:
> sugar3.bundle.bundle.MalformedBundleException: Activity bundle /home/olpc
> /.sugar/default/data/d84ff538-7200-47b1-92fd-2e4962f73e50_dQxXr5.xo does not
> specify a bundle id
> Regular get books installs and works well
>
> read works
>
> color chooser in write is laggy, but otherwise write works
>
> tamtam mini 67 got caught in an inifnite loop, see https://sugardextrose.org/
> issues/3880 this was not repeatable
>
> paint- can’t choose font when using text boxes with trackpad or touchscreen
> maybe due to wear the menu drops down, bold and italic works
>
> works - moon, maze, implode, memorize, clock, stopwatch, physics, write
> nice improvements in speak for visual tool identification
> nice improvements in record for visual tool identification
>
> ran software updates - fraction bounce and level activities work
>
> write full test works
> record works
> browse basic test works
>
> _______________________________________________
> OLPC-NZ mailing list
> [hidden email]
> http://lists.laptop.org/listinfo/olpc-nz
>


> _______________________________________________
> OLPC-AU mailing list
> [hidden email]
> http://lists.laptop.org/listinfo/olpc-au



--
James Cameron
http://quozl.linux.org.au/
_______________________________________________
Testing mailing list
[hidden email]
http://lists.laptop.org/listinfo/testing
Reply | Threaded
Open this post in threaded view
|

Re: Auckland Testing Summary 18 May 2013

carrott
On 18/05/13 16:17, James Cameron wrote:
> On Sat, May 18, 2013 at 03:52:42PM +1200, Tom Parker wrote:
>> One Education OS 1.2 (build au889) on XO-1.75:
>> Sound doesn’t work due to OLPC #12637 downgrading the firmware to
>> Q4D24 fixes it.
>
> What firmware version was installed?

Our XO-1.75s had Q4D27 and Q4D28.

> What firmware version is in au889?

How do you tell? I did searched the running laptop's filesystem for a
.rom file with the goal of installing that version but didn't find one,
so used Q4D24 as recommended on #12637
_______________________________________________
Testing mailing list
[hidden email]
http://lists.laptop.org/listinfo/testing
Reply | Threaded
Open this post in threaded view
|

Re: Auckland Testing Summary 18 May 2013

James Cameron-2
On Sat, May 18, 2013 at 05:08:26PM +1200, Tom Parker wrote:
> On 18/05/13 16:17, James Cameron wrote:
> >On Sat, May 18, 2013 at 03:52:42PM +1200, Tom Parker wrote:
> >>One Education OS 1.2 (build au889) on XO-1.75:
> >>Sound doesn’t work due to OLPC #12637 downgrading the firmware to
> >>Q4D24 fixes it.
> >
> >What firmware version was installed?
>
> Our XO-1.75s had Q4D27 and Q4D28.

Thanks.  This problem was fixed in Q4D29.  Please try with Q4D29?
http://wiki.laptop.org/go/OLPC_Firmware_q4d29

> >What firmware version is in au889?
>
> How do you tell? I did searched the running laptop's filesystem for
> a .rom file with the goal of installing that version but didn't find
> one, so used Q4D24 as recommended on #12637

#12637 didn't recommend that, but it did say that the last known
working version was Q4D24.

If au889 contains anything after Q4D24 then it will automatically
reflash next time it has a power cord attached.  I don't know enough
about au889.

The file should be bootfw2.zip in the /boot directory, and it contains
two files, the data.img file will have an md5sum matching one of
these:

1f61697d66aef3f29bbc0dd69a2dd4c7  q4d24.rom
0effc8d732e847b1245da3cb0da1ec5e  q4d25.rom
09baa37cb297cacff565f1a4a0a298b2  q4d26.rom
0d518ab0f9dd63cd64035202674f5be7  q4d27.rom
da7189125f1e37f56d6e36f0dbc05aa7  q4d28.rom
7e443310a1d8c92b1a683fc8113fd900  q4d29.rom

The file is provided by an RPM package, so you may find the version
also confirmed by:

        sudo rpm -q olpc-firmware

The download directory for au889 might also have a packages file that
lists an olpc-firmware package version.

--
James Cameron
http://quozl.linux.org.au/
_______________________________________________
Testing mailing list
[hidden email]
http://lists.laptop.org/listinfo/testing
Reply | Threaded
Open this post in threaded view
|

Re: Auckland Testing Summary 18 May 2013

carrott
On 18/05/13 22:00, James Cameron wrote:

> On Sat, May 18, 2013 at 05:08:26PM +1200, Tom Parker wrote:
>> On 18/05/13 16:17, James Cameron wrote:
>>> On Sat, May 18, 2013 at 03:52:42PM +1200, Tom Parker wrote:
>>>> One Education OS 1.2 (build au889) on XO-1.75:
>>>> Sound doesn’t work due to OLPC #12637 downgrading the firmware to
>>>> Q4D24 fixes it.
>>>
>>> What firmware version was installed?
>>
>> Our XO-1.75s had Q4D27 and Q4D28.
>
> Thanks.  This problem was fixed in Q4D29.  Please try with Q4D29?
> http://wiki.laptop.org/go/OLPC_Firmware_q4d29

Sound doesn't work with Q4D29. This image has kernel
3.0.19_xo1.75-20120714.1244.olpc.91e4ce2

> The file should be bootfw2.zip in the /boot directory, and it contains
> two files, the data.img file will have an md5sum matching one of
> these:

It doesn't have a /boot/bootfw2.zip

> sudo rpm -q olpc-firmware

It has olpc-firmware-q4d15-1.unsigned.noarch
_______________________________________________
Testing mailing list
[hidden email]
http://lists.laptop.org/listinfo/testing
Reply | Threaded
Open this post in threaded view
|

Re: Auckland Testing Summary 18 May 2013

James Cameron-2
On Sun, May 19, 2013 at 09:25:50AM +1200, Tom Parker wrote:

> On 18/05/13 22:00, James Cameron wrote:
> >On Sat, May 18, 2013 at 05:08:26PM +1200, Tom Parker wrote:
> >>On 18/05/13 16:17, James Cameron wrote:
> >>>On Sat, May 18, 2013 at 03:52:42PM +1200, Tom Parker wrote:
> >>>>One Education OS 1.2 (build au889) on XO-1.75:
> >>>>Sound doesn’t work due to OLPC #12637 downgrading the firmware to
> >>>>Q4D24 fixes it.
> >>>
> >>>What firmware version was installed?
> >>
> >>Our XO-1.75s had Q4D27 and Q4D28.
> >
> >Thanks.  This problem was fixed in Q4D29.  Please try with Q4D29?
> >http://wiki.laptop.org/go/OLPC_Firmware_q4d29
>
> Sound doesn't work with Q4D29. This image has kernel
> 3.0.19_xo1.75-20120714.1244.olpc.91e4ce2

Wow.  Okay.  Ten months ago.

> >The file should be bootfw2.zip in the /boot directory, and it contains
> >two files, the data.img file will have an md5sum matching one of
> >these:
>
> It doesn't have a /boot/bootfw2.zip

Yes, it would probably predate that.

> > sudo rpm -q olpc-firmware
>
> It has olpc-firmware-q4d15-1.unsigned.noarch

I suggest not using that build with firmware after Q4D24, because our
fix in Q4D29 probably has a kernel dependency.

--
James Cameron
http://quozl.linux.org.au/
_______________________________________________
Testing mailing list
[hidden email]
http://lists.laptop.org/listinfo/testing
Reply | Threaded
Open this post in threaded view
|

Re: Auckland Testing Summary 18 May 2013

carrott
On 20/05/13 10:37, James Cameron wrote:
>> Sound doesn't work with Q4D29. This image has kernel
>> 3.0.19_xo1.75-20120714.1244.olpc.91e4ce2
>
> Wow.  Okay.  Ten months ago.

This is apparently the build that One Education want to use in New
Zealand this year.
_______________________________________________
Testing mailing list
[hidden email]
http://lists.laptop.org/listinfo/testing
Reply | Threaded
Open this post in threaded view
|

Re: Auckland Testing Summary 18 May 2013

Gonzalo Odiard-3
In reply to this post by carrott

Testing One Education OS 1.2 (build au889) on XO-1.75 and XO-system 1a for XO-4 (build 32) on XO-4.

Browse is really old and slow! Many websites work badly!


What version is that? (you can see the number in the list view in the home)


paint- can’t choose font when using text boxes with trackpad or touchscreen maybe due to wear the menu drops down, bold and italic works


Can you explain a little more what the problem is?

Gonzalo

_______________________________________________
Testing mailing list
[hidden email]
http://lists.laptop.org/listinfo/testing
Reply | Threaded
Open this post in threaded view
|

Re: Auckland Testing Summary 18 May 2013

carrott
On 20/05/13 23:20, Gonzalo Odiard wrote:
>
>     Testing One Education OS 1.2 (build au889) on XO-1.75 and XO-system
>     1a for XO-4 (build 32) on XO-4.
>
>     Browse is really old and slow! Many websites work badly!
>
>
> What version is that? (you can see the number in the list view in the home)

This build has Browse 192.3 which is based on firefox.

_______________________________________________
Testing mailing list
[hidden email]
http://lists.laptop.org/listinfo/testing
Reply | Threaded
Open this post in threaded view
|

Re: Auckland Testing Summary 18 May 2013

Manuel Quiñones-2
2013/5/22 Tom Parker <[hidden email]>:

> On 20/05/13 23:20, Gonzalo Odiard wrote:
>>
>>
>>     Testing One Education OS 1.2 (build au889) on XO-1.75 and XO-system
>>     1a for XO-4 (build 32) on XO-4.
>>
>>     Browse is really old and slow! Many websites work badly!
>>
>>
>> What version is that? (you can see the number in the list view in the
>> home)
>
>
> This build has Browse 192.3 which is based on firefox.

That is for XO-4 touch?  You will be missing the touch scrolling.  If
you are shipping Sugar 0.98, then Browse 149.3 is the latest and
contains important improvements.

--
.. manuq ..
_______________________________________________
Testing mailing list
[hidden email]
http://lists.laptop.org/listinfo/testing
Reply | Threaded
Open this post in threaded view
|

Re: Auckland Testing Summary 18 May 2013

carrott
On 23/05/13 23:57, Manuel Quiñones wrote:

> 2013/5/22 Tom Parker <[hidden email]>:
>> On 20/05/13 23:20, Gonzalo Odiard wrote:
>>>
>>>
>>>      Testing One Education OS 1.2 (build au889) on XO-1.75 and XO-system
>>>      1a for XO-4 (build 32) on XO-4.
>>>
>>>      Browse is really old and slow! Many websites work badly!
>>>
>>>
>>> What version is that? (you can see the number in the list view in the
>>> home)
>>
>>
>> This build has Browse 192.3 which is based on firefox.
>
> That is for XO-4 touch?  You will be missing the touch scrolling.  If
> you are shipping Sugar 0.98, then Browse 149.3 is the latest and
> contains important improvements.

This is for the XO-1.75.

How is Browse 192.3 "newer" than Brows 149.3?

_______________________________________________
Testing mailing list
[hidden email]
http://lists.laptop.org/listinfo/testing
Reply | Threaded
Open this post in threaded view
|

Re: [OLPC New Zealand] Auckland Testing Summary 18 May 2013

Tabitha Roder-5
In reply to this post by Gonzalo Odiard-3


paint- can’t choose font when using text boxes with trackpad or touchscreen maybe due to wear the menu drops down, bold and italic works


Can you explain a little more what the problem is?

Gonzalo


In Paint activity there is a text box tool. You use it to add text to your picture. You should be able to choose the font for the text, but when you click the font option you get a drop down menu quite far to the right of where the font button is. It is not possible to change the font, it seems to ignore your clicks and your screen touches.
Tabitha

_______________________________________________
Testing mailing list
[hidden email]
http://lists.laptop.org/listinfo/testing
Reply | Threaded
Open this post in threaded view
|

Re: [OLPC New Zealand] Auckland Testing Summary 18 May 2013

Walter Bender-4
On Sun, May 26, 2013 at 1:54 AM, Tabitha Roder <[hidden email]> wrote:

>
>>>
>>> paint- can’t choose font when using text boxes with trackpad or
>>> touchscreen maybe due to wear the menu drops down, bold and italic works
>>>
>>
>> Can you explain a little more what the problem is?
>>
>> Gonzalo
>>
>
> In Paint activity there is a text box tool. You use it to add text to your
> picture. You should be able to choose the font for the text, but when you
> click the font option you get a drop down menu quite far to the right of
> where the font button is. It is not possible to change the font, it seems to
> ignore your clicks and your screen touches.

Gonzalo,

I suspect this is related to the font blacklist issue we've been
discussing. Perhaps the more aggressive list I sent you in my latest
Labyrinth patch would be useful here.

regards.

-walter


> Tabitha
>
> _______________________________________________
> Devel mailing list
> [hidden email]
> http://lists.laptop.org/listinfo/devel
>



--
Walter Bender
Sugar Labs
http://www.sugarlabs.org
_______________________________________________
Testing mailing list
[hidden email]
http://lists.laptop.org/listinfo/testing
Reply | Threaded
Open this post in threaded view
|

Re: [OLPC New Zealand] Auckland Testing Summary 18 May 2013

Gonzalo Odiard-3
In reply to this post by Tabitha Roder-5
Thanks Tabitha.
This happen every time or only some times?
In theory, you can change the font while you are editing the text, 
or before you start to insert a text in the image.
There are a bug associated to the combo in gtk3, when there are more options 
than available vertical space in the screen: the first time the combo is opened,
the arrows at top and at bottom are not visible. If you close the combo and open it again,
arrows are displayed and you can navigate the options. Is that the situation?
We are discussing with Walter other options to select fonts, 
but need more work in my opinion. We can send activities to test by your group,
should be good have feedback, before pushing to all the users.

Gonzalo  


On Sun, May 26, 2013 at 2:54 AM, Tabitha Roder <[hidden email]> wrote:


paint- can’t choose font when using text boxes with trackpad or touchscreen maybe due to wear the menu drops down, bold and italic works


Can you explain a little more what the problem is?

Gonzalo


In Paint activity there is a text box tool. You use it to add text to your picture. You should be able to choose the font for the text, but when you click the font option you get a drop down menu quite far to the right of where the font button is. It is not possible to change the font, it seems to ignore your clicks and your screen touches.
Tabitha


_______________________________________________
Testing mailing list
[hidden email]
http://lists.laptop.org/listinfo/testing